1. It is better to sign-up/log-in before you post your question (or reply to an existing thread), instead of posting as a guest.
    This will allow you to easily look up the Q&A sequence anytime, anywhere, with just one mouse click. Learn more...

    You can log in with your Facebook, Twitter, or Google+ accounts, or create a KVMGalore HelpCenter user-name/password.
    Dismiss Notice

Switch KVM Switch with conference camera

Discussion in 'KVM' started by Ryan Eckhardt, Sep 14, 2017.

  1. Ryan Eckhardt

    Ryan Eckhardt New member

    I have an IOGear GCS1932-KM which is working great for everything except for my conference room camera.

    I have tried two different cameras:
    • HuddleCamHD 10X-GY-G3 2.1 MP 1080p PTZ Camera
    • TelyCam 12x HD USB PTZ 3.0 Video Conference Camera
    When I plug in each camera directly to the PC everything works fine. When I plug it into the IOGear switch it doesn't recognize the camera, or it will for a couple minutes and then freezes. Note that all other items work great on the switch (projector, keyboard, mouse, speakers). I have tried plugging other devices into the same port that I'm using for the camera and it works fine. So I know the port is working.

    IOGear says that they "guess the camera just doesn't and I'll have to plug it into the computer".

    Can anyone suggest a KVM switch that uses display-port, USB3, switches 2 devices, and has Hotkey capabilities that also switches a conference room camera?

    Thank you
  2. KVMGalore Expert

    KVMGalore Expert Staff Member

    Which port on your GCS1932 are you using to connect your camera? Could you send us a picture?
  3. Ryan Eckhardt

    Ryan Eckhardt New member

    I've added two files:
    • Front.jpg
    • Back.jpg
    The front picture shows where I've been putting the camera. The back shows (with the rudimentary arrow) where the other USB3 port is located. Currently I have an audio device plugged in there.

    I have switched these two cables and put the camera into the port where the audio currently is and that did not change the result. It still didn't work.

    Attached Files:

  4. KVMGalore Expert

    KVMGalore Expert Staff Member

    You are definitely using the correct ports.

    Does your audio device (or any other USB device) work properly when connected to either one of these two USB 3 ports? (We're guessing 'Yes", which would rule out the GCS1932 being defective).
  5. Ryan Eckhardt

    Ryan Eckhardt New member

    Yes I've switched my audio device between both ports and plugged in other items to both ports and it works perfectly. It just won't recognize either camera.

    BTW... I have tried a Microsoft Lifecam. USB2, 720P small camera and it works flawlessly with the switch. It just seems like the switch can't handle the data of a USB3 camera. Or USB3 is really picky.
  6. KVMGalore Expert

    KVMGalore Expert Staff Member

    You appear to be using the IOGear GCS1932 correctly, and based on its specs it should be able to share USB 3.0 peripherals.

    Is it possible that your cameras only support USB 3.1 (Gen 2)?
  7. Ryan Eckhardt

    Ryan Eckhardt New member

    The only information I can find on the Telycam TLC-300-U3s is that its output is USB3.0 Super Speed Transit.
  8. KVMGalore Expert

    KVMGalore Expert Staff Member

    Very odd, as IOGear GCS1932 does support sharing USB 3.0 peripherals.

    We suspect either...
    a) These cameras are incompatible with USB 3.0 (perhaps they are USB 3.1 Gen 2); or
    b) These camera do not use standard USB protocol.

    Either way, is is very possible you will experience the exact same problem with any other KVM switch, as it appears you are using it absolutely correctly and as intended.

Share This Page